Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14306 closed bug (duplicate)

SETTING "WRONG" VALUE OF SELECT-ELEMENT USING .VAL() IS INCONSISTENT IN FF COMPARED TO OTHER BROWSERS

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Check this Fiddle: http://jsfiddle.net/ECFYX/9/

If the page has a select-element and the value for the select-element is changed using .val(xxx) but with a value that isn't found in the select-element's options then FF changes the select element to show an empty option, in all other browsers tested (IE, Safari, Chrome) it changes the selected value to be the first option.

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #14349.

Note: See TracTickets for help on using tickets.