Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14242 closed feature (notabug)

Internet Explorer 11 User Agent String Support

Reported by: Shifeng.Li@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

Dear JQuery Technical Expert,

I am Shifeng Li in Austin. I would like to ask about JQuery.org product release plan to support the new IE 11 browser User Agent string.

The IE 11 browser has changed the User Agent String to “Mozilla/5.0 (Windows NT 6.3; Trident/7.0; rv 11.0) like Gecko”.

As we can see, the IE 11 browser User Agent String no longer contains the “MSIE”, plus the browser version is now separated away from “MSIE”, but defined as “rv 11.0”.

In many current JQuery plug-ins/libraries, the IE browser information is being retrieved by using the navigator.userAgent to get the user agent string, then applying regular expression match on “msie”, or by using $.browser.msie and $.browser.version to detect IE browser information in older 1.8 JQuery.

So, would like to know if JQuery.org will soon release the new plug-ins and libraries to support the IE browser and version detection that can support IE 11 and older IE versions.

Thanks in advance for your information.

Shifeng

Change History (3)

comment:1 Changed 6 years ago by Rick Waldron

Resolution: notabug
Status: newclosed

comment:2 Changed 6 years ago by EcoiSerg@…

If you add the following line just before one checking for mozilla type browsers, you will be able to identify MSie 11 as "trident" "11.0" :

ua.indexOf("compatible") < 0 && /(trident)(?:.*? rv ([\w.]+)|)/.exec( ua )

Now the question is whether one wants to really consider MSie 11.0 has MSie or as something else, such as Trident ?

Then again, one should really check on availability of features rather than browser name/type and version.

comment:3 in reply to:  description Changed 6 years ago by EcoiSerg@…

Replying to Shifeng.Li@…:

Dear JQuery Technical Expert,

I am Shifeng Li in Austin. I would like to ask about JQuery.org product release plan to support the new IE 11 browser User Agent string.

The IE 11 browser has changed the User Agent String to “Mozilla/5.0 (Windows NT 6.3; Trident/7.0; rv 11.0) like Gecko”.

As we can see, the IE 11 browser User Agent String no longer contains the “MSIE”, plus the browser version is now separated away from “MSIE”, but defined as “rv 11.0”.

In many current JQuery plug-ins/libraries, the IE browser information is being retrieved by using the navigator.userAgent to get the user agent string, then applying regular expression match on “msie”, or by using $.browser.msie and $.browser.version to detect IE browser information in older 1.8 JQuery.

So, would like to know if JQuery.org will soon release the new plug-ins and libraries to support the IE browser and version detection that can support IE 11 and older IE versions.

Thanks in advance for your information.

Shifeng


Bonjour,

If you add the following line just before one checking for mozilla type browsers, you will be able to identify MSie 11 as "trident" "11.0" :

ua.indexOf("compatible") < 0 && /(trident)(?:.*? rv ([\w.]+)|)/.exec( ua )

Now the question is whether one wants to really consider MSie 11.0 has MSie or as something else, such as Trident ? MSie 11.0 is really an attempt by MicroSoft to get back in line with all the other browsers 'dropping' many of the particuliarities of older MSie ... not without creating new issues.

Then again, one should really check on availability of features rather than browser name/type and version. Microsoft seems to have taken the route to report lack of support of older MSie 'features', in hopes people will stop checking for and using them, while secretely still supporting at least some of them to avoid crashing many sites still depending on these MSie specific features.

Serge EcoiSerg@gmail.com

Note: See TracTickets for help on using tickets.