Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14218 closed bug (duplicate)

jQuery.Callbacks breaks future promises if a callback function throws

Reported by: beneidel@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.3
Keywords: Cc:
Blocked by: Blocking:

Description

if a callback throws an error, the subsequent callbacks won't get called because a flag named "firing" stays true forever. This seems to be fixed easily using a try/finally block.

jsfiddle demostrating this (using $(fn) shortcut for $(document).ready()) http://jsfiddle.net/benjamine/g3EF3/3/

Change History (1)

comment:1 Changed 6 years ago by jaubourg

Resolution: duplicate
Status: newclosed

Duplicate of #14201 .

Note: See TracTickets for help on using tickets.