Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14214 closed bug (duplicate)

remove leaking memory in IE8

Reported by: lorenzo.dallavecchia@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc: dmethvin
Blocked by: Blocking:

Description

Calling .remove on a set of matched elements they are indeed removed from the DOM, but IE8 keeps internal references to them, leaking memory.

This is probably due to a bug in IE8 implementation of removeChild. Adding the a call to removeNode does seem to remove the leak.

node.removeNode(false);

To reproduce, copy the fiddle at http://jsfiddle.net/H3jQc/ to a local file and run it through sIEve on a computer with IE8 installed. Each time the Test button is clicked, one SPAN element is leaked.

The problem does not show in IE9 or later. jQuery versions from at least 1.7.2 to the latest 1.10.x seem to be affected.

Change History (2)

comment:1 Changed 6 years ago by timmywil

Cc: dmethvin added

I currently don't have a way to test for oldIE memory leaks on my machine. @dmethvin: do you have a way?

comment:2 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #14045.
This is most likely related to #14045, but even if it's not, let's resolve both with the one leak ticket and possible inclusion of .removeNode().

Note: See TracTickets for help on using tickets.