Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14199 closed bug (duplicate)

Event received twice if fired by jquery

Reported by: martin.samek@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Change History (5)

comment:1 Changed 6 years ago by dmethvin

#14200 is a duplicate of this ticket.

comment:2 Changed 6 years ago by dmethvin

The event is bubbling, as it should. Please ask for help on a forum.

comment:3 Changed 6 years ago by dmethvin

I take that back, the inline handler seems like it should only be called once.

http://jsfiddle.net/ewh8c/1/

comment:4 Changed 6 years ago by martin.samek@…

When listener is attached by jQuery, it is called also once. http://jsfiddle.net/ewh8c/2/

comment:5 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #10168.
See the duplicate ticket. Inline handlers are going to be executed twice for these edge cases, you can .stopPropagation() as a solution or better yet, don't use inline handlers.

Note: See TracTickets for help on using tickets.