Bug Tracker

Opened 7 years ago

Closed 7 years ago

#14175 closed bug (duplicate)

In IE10 $.get() doesn't make a request when passed an empty object as params

Reported by: marshall@… Owned by: marshall@…
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.3
Keywords: Cc:
Blocked by: Blocking:

Description

Example here: http://jsfiddle.net/96NuG/

In Chrome and Firefox, $.get() requests the url without a querystring when passed {} as params as expected. In IE10, no request is made and the callback is never called. In all browsers, .get() works as expected when there is a key in the params hash (as seen in the jsfiddle)

Same results in both 1.10 and 2.0

Change History (3)

comment:1 Changed 7 years ago by dmethvin

Owner: set to marshall@…
Status: newpending

Are you expecting a request to be made to the server? If so the URL should be "/#" and not just "#".

comment:2 Changed 7 years ago by marshall@…

Status: pendingnew

I suppose I see your point (though "/#" requests the domain root, not the current page). "./" or "" also works in all browsers. "#" does work in everything but IE though which is a strange inconsistency, especially because '#' is removed by jQuery anyway ( https://github.com/jquery/jquery/blob/master/src/ajax.js#L414 ).

I don't know the source well enough to figure how IE could possibly do this. It's unexpected behavior but I'm sure it's not worth spending all day on if the cause isn't fairly obvious.

Thanks for your response.

comment:3 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #11023.

Note: See TracTickets for help on using tickets.