Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14158 closed bug (invalid)

$.ajax() on v2.0.3 under Jasmine 2 throws DOM Exception 12

Reported by: jose@… Owned by: jose@…
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.3
Keywords: Cc:
Blocked by: Blocking:

Description

I have provided a Git repository that demonstrates the error: https://github.com/josemota/solid-javascript-example/tree/8bd940953e6930cf46a670f1bbbbf830d36953cf. I have indeed tried to provide a jsFiddle but I was unable to provide a working JSON file in there to best reproduce the bug.

I am calling $.ajax under a Jasmine suite in the browser. The test (/js/test/promises.js) calls it (/js/lib/promises.js) but I get a DOM Exception 12 and so the test fails. Information on the stack trace and more can be seen in the commit message: https://github.com/josemota/solid-javascript-example/commit/8bd940953e6930cf46a670f1bbbbf830d36953cf

Let me know if I can provide more useful information. Thank you, -- José Mota @josemotanet

Change History (2)

comment:1 Changed 6 years ago by dmethvin

Owner: set to jose@…
Status: newpending

Please provide an example that just includes jQuery core. If the problem only arises when Jasmine or other components are included, it could be that they are calling jQuery incorrectly.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.