Bug Tracker

Opened 7 years ago

Closed 7 years ago

#14152 closed bug (worksforme)

IE7: [type="anything"] selector throws "Object doesn't support this property or method"

Reported by: spudly Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

The following selector will throw an error in real versions of Internet Explorer 7:

$('[type="something"]');

It throws this error: Object doesn't support this property or method with no file or line information to tell you where it came from.

This happens in a real version of IE7 only! It cannot be reproduced in ie7 browser mode or ie7 document mode. I had to download microsoft's ie7 virtual machine image in order to debug this.

Works fine in 1.9.1. Broken in both 1.10.1 and 1.10.2.

This seems to be related to Ticket #13974, but the fix for that ticket did not fix this issue.

Change History (1)

comment:1 Changed 7 years ago by timmywil

Resolution: worksforme
Status: newclosed

jquery-git works for me in real IE7. http://jsbin.com/exuked/1/

Note: See TracTickets for help on using tickets.