Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14128 closed bug (invalid)

Not loading script from localhost without "crossDomain: true"

Reported by: 4analit@… Owned by: 4analit@…
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.3
Keywords: Cc:
Blocked by: Blocking:

Description

$.ajax({
    url: "http://localhost:8000/js/foo.js",
    dataType: "script",
});

Script loading but not eval.

$.ajax({
    url: "http://localhost:8000/js/foo.js",
    crossDomain: true,
    dataType: "script",
});

All good.

Runing from http://localhost:8000

Same with relative path: "js/foo.js".

Maybe it's feature, but it's not clear from documentation.

Change History (2)

comment:1 Changed 6 years ago by dmethvin

Owner: set to 4analit@…
Status: newpending

The problem isn't clear from the description either. Is the page running this request at localhost or is it at localhost:8000? The latter would indeed be cross domain.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.