Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14105 closed bug (duplicate)

$(object).css("border") doesn´t work in Firefox

Reported by: manuel.simon.steinberg@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

I try to read the border css with the script in summary and everytime i get null as callback. i tried other options, e.g. "border-width" or "border-color", it doesn´t work in Firefox. In Opera it works!

Change History (1)

comment:1 Changed 6 years ago by gibson042

Resolution: duplicate
Status: newclosed

Duplicate of #13421.
From http://api.jquery.com/css/:

[Retrieval of] Shorthand CSS properties (e.g. margin, background, border) are not supported. For example, if you want to retrieve the rendered margin, use: $(elem).css('marginTop') and $(elem).css('marginRight'), and so on.

Use guaranteed-readable properties like "border-left-width", "border-bottom-color", etc.

Note: See TracTickets for help on using tickets.