Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14097 closed bug (duplicate)

jQuery(HTML) won't work if HTML has leading whitespace(s)

Reported by: ewk_000@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hi, I'm in the process of upgrading to 1.9.1 and my application started crashing since it uses client-side templates which may at times contain leading whitespaces.

I know this issue is not new and has been dealt with for version 1.10, as specified in ticket http://bugs.jquery.com/ticket/13223.

However this issue was first introduced in 1.9.1 and should be fixed for it as well.

Not all can just upgrade, for instance JQM supports up till version 1.9.1.

This probably breaks code on thousands of sites that use client-side templates not to mention enterprise grade code using jQuery, that can't just be refactored in reasonable effort.

Thanks

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13223.
We don't change code in versions that have already been released. Despite the change in 1.10 we still recommend using $.parseHTML() for parsing arbitrary HTML.

Note: See TracTickets for help on using tickets.