Bug Tracker

Opened 7 years ago

Closed 7 years ago

#14081 closed bug (duplicate)

1.10.1 giving erroneous "SCRIPT5: Access is denied" error in IE9 and IE10

Reported by: rich@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

Original StackOverflow question: http://stackoverflow.com/questions/17370482/catching-cross-domain-errors-in-ie

Scenario: Page A on A.com that has an IFrame containing Page B on B.com. Page B uses jQuery 1.10.1 and does not need to communicate with Page A.

Regardless of this fact, in IE9 and IE10, jQuery generates a "SCRIPT5: Access is denied." error and seemingly refuses to execute any jQuery at all. I have no need of cross-domain communication, AJAX requests, etc., but I do need jQuery to load and execute without errors in Page B.

jsFiddle: http://jsfiddle.net/86q5k/4/

Using jQuery 1.10.0 (instead of 1.10.1) seems to resolve this issue: http://jsfiddle.net/86q5k/5/

Change History (1)

comment:1 Changed 7 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #13980.

Note: See TracTickets for help on using tickets.