Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14077 closed bug (invalid)

jQuery doesn't calculate correct width and height v1.9.0 (correct) vs 1.10.1 (incorrect) IE9

Reported by: garnayden@… Owned by: garnayden@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have used jQuery Layout UI from time ago. Recently I upgraded my jQuery code to version 1.10.1, but the height and width of the pane it doesn't calculate correctly when I use a css for add padding. This problem occurs only in IE. It seems the method that cause the problem is

height()

and

width()

Here are the example that show the behavior: http://jsbin.com/utukip/3/ I taken the complex sample from jquery layout ui. If I change the jquery imported and use it: http://code.jquery.com/jquery-1.10.1.js It doesn't work, but if I change to: http://code.jquery.com/jquery-1.9.0.js It works great :D

I hope this is useful.

Change History (2)

comment:1 Changed 6 years ago by timmywil

Owner: set to garnayden@…
Status: newpending

There's a lot of code in that example. To help us assess the issue, please reduce the test case so that only jQuery core is included and a problem with width/height can be demonstrated.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.