Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14067 closed bug (invalid)

This is undebuggable

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

I am sure there's something wrong in my own code, and I am sorry I can't provide a jsbin reproducing the issue. However, when an UNCAUGHT error is thrown and the whole backtrace does not mention a single line of code outside JQuery and JqueryMobile, it is by definition a bug in either of them, even if triggered by broken code on the custom code side calling jquery.

Here the backtrace:

Uncaught TypeError: Object function (b,c,d){var e=b.split(".")[0],f;b=b.split(".")[1],f=e+"-"+b,d||(d=c,c=a.Widget),a.expr[":"][f]=function(c){return!!a.data(c,b)},a[e]=a[e]||{},a[e][b]=function(a,b){arguments.length&&this._createWidget(a,b)};var g=new c;g.options=a.extend(!0,{},g.options),a[e][b].prototype=a.extend(!0,g,{namespace:e,widgetName:b,widgetEventPrefix:a[e][b].prototype.widgetEventPrefix||b,widgetBaseClass:f},d),a.widget.bridge(b,a[e][b])} has no method 'extend' jquery.mobile-1.3.1.js:586
$.Widget._createWidget jquery.mobile-1.3.1.js:586
$.(anonymous function).(anonymous function) jquery.mobile-1.3.1.js:416
(anonymous function) jquery.mobile-1.3.1.js:559
jQuery.extend.each jquery.js:660
jQuery.fn.jQuery.each jquery.js:271
$.fn.(anonymous function) jquery.mobile-1.3.1.js:554
(anonymous function) jquery.mobile-1.3.1.js:1116
jQuery.event.dispatch jquery.js:3332
elemData.handle.eventHandle jquery.js:2941
jQuery.event.trigger jquery.js:3210
(anonymous function) jquery.js:3869
jQuery.extend.each jquery.js:660
jQuery.fn.jQuery.each jquery.js:271
jQuery.fn.extend.trigger jquery.js:3868
$.extend.initializePage jquery.mobile-1.3.1.js:11102
(anonymous function) jquery.mobile-1.3.1.js:11168
fire jquery.js:1075
self.fireWith jquery.js:1193
jQuery.extend.ready jquery.js:435
DOMContentLoaded jquery.js:949

One of the reasons I can't provide a test case is the nature of the issue itself: it's not giving me any clue about what code of mine is triggering the issue, and I can't reproduce my whole website on a jsbin.

If I am doing something wrong in my code (which is _certainly_ the case), then either jquery or jquerymobile _must_ throw an understandable error message explaining how it is being abused, unless it can be evinced from the backtrace.

Change History (2)

comment:1 Changed 6 years ago by Rick Waldron

Owner: set to anonymous
Status: newpending

Try using the non-minified code...

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.