Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1404 closed bug (duplicate)

Radio buttons are unchecked when parent element is shown via show() in IE 6

Reported by: brockweaver Owned by:
Priority: major Milestone: 1.1.4
Component: core Version: 1.1.3
Keywords: visible form radio button Cc:
Blocked by: Blocking:

Description

Checked radio buttons lose their checked state when a containing element is shown via show() and animation is used (e.g. show('fast') or show('slow')) in IE 6. Does not occur in FF2. Using DOCTYPE XHTML 1.0 Transitional. Commenting out line 404 in jquery-1.1.3.1.js causes just the opposite behavior -- FF2 loses checked state while IE6 does not.

See attached file for an example.

Attachments (1)

example_error.html (1.9 KB) - added by brockweaver 13 years ago.
HTML describing and test harness for testing fix of radio buttons becoming unchecked in IE 6

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by brockweaver

Attachment: example_error.html added

HTML describing and test harness for testing fix of radio buttons becoming unchecked in IE 6

comment:1 Changed 13 years ago by brockweaver

I apologize, this is a dupe of #1095.

comment:2 Changed 13 years ago by brandon

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.