Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14030 closed bug (duplicate)

input $(this).is(':focus') return false on focus event (chrome)

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

Browser: Google Chrome 27.0.1453.110 m (Works in Firefox 21.0)
Code: http://jsbin.com/uworek/1/

Expected result: Console logs true on focus
Real result: Console logs false on focus
(Sometimes false, false, true the first time and false afterwards)

Changing the jQuery version to 1.9.1 fixes the problem. 1.10.0 doesn't work either.

Change History (3)

comment:1 Changed 6 years ago by anonymous

Related:
#10569 (The same thing happened 20 months ago)
#13794

comment:2 Changed 6 years ago by dmethvin

I think it may be related to this WebKit bug: https://code.google.com/p/chromium/issues/detail?id=96385

We had a workaround at one point using document.activeElement but that was causing issues in IE.

comment:3 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #13794.
This is a known bug, but as Dave said, the workaround required accessing activeElement more often, which crashed in IE in certain situations. Closing as duplicate of #13794. We'll track it there.

Note: See TracTickets for help on using tickets.