Bug Tracker

Opened 7 years ago

Closed 7 years ago

#14020 closed bug (duplicate)

.css() method inconsistance results in different browsers

Reported by: lockheedman@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Trying to get border of an element using css method works only in Opera and Chrome. IE8+ and FireFox gives NaN or nothing (IE10). The same is with older versions of library

http://jsfiddle.net/EMjJD/3/

Change History (1)

comment:1 Changed 7 years ago by gibson042

Resolution: duplicate
Status: newclosed

Duplicate of #13421.
From http://api.jquery.com/css/:

[Retrieval of] Shorthand CSS properties (e.g. margin, background, border) are not supported. For example, if you want to retrieve the rendered margin, use: $(elem).css('marginTop') and $(elem).css('marginRight'), and so on.

Note: See TracTickets for help on using tickets.