Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14015 closed bug (duplicate)

Attribute selector not working

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.2
Keywords: Cc:
Blocked by: Blocking:

Description

The attribute selector is not working in IE 9 in 2.0.2 (according to jsfiddle it doesnt work in IE 10 either but I have it working when not using jsfiddle).

See example: http://jsfiddle.net/QPG38/9/

If changed to jquery version 1.9.1 it works in IE 10 but not in IE9 (when selecting by type=search).

So the general problem is that attribute selector does not work in IE 9 when selecting by type=search for an example.

Change History (4)

comment:1 Changed 6 years ago by markelog

Resolution: duplicate
Status: newclosed

Duplicate of #13980.

comment:2 Changed 6 years ago by anonymous

I don't see how it relates to an iframe issue. It is not working for me and I don't load it in an iframe.

The attribute selector does not work in IE 9 when trying to get type=search, and it doesn't work in old versions of jquery either.

comment:3 Changed 6 years ago by dmethvin

Does it work with the jquery-git.js?

I had thought I had seen a similar situation in the recent past with IE10 taking an <input type="search"> and turning it into an <input type="text">. Maybe it was fixed? If it is still failing for you, open F12 tools and inspect the HTML. Does it say search, or text?

comment:4 Changed 6 years ago by anonymous

Aha, ... thanks for the reply.

You are right, IE 9 seems to turn the <input type="search" /> into type="text" by itself. So it haven't got anything to do with jQuery then.

Weird.

Note: See TracTickets for help on using tickets.