Bug Tracker

Opened 7 years ago

Closed 7 years ago

#14012 closed bug (duplicate)

done/fail/always callbacks not called for HTTP status code 202

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.2
Keywords: Cc:
Blocked by: Blocking:

Description

My server returns status code 202 upon successful DELETE request. My client code makes a jQuery AJAX call to issue DELETE request. I tried all combinations of including done/fail/always and success/error/complete callbacks. I see that done/fail/always callbacks are never called, but success/error/complete are called. I also included a callback for statusCode 202, and I see that was called AFTER the success callback was called.

Since success/error/complete callbacks are deprecated, it seems to me that done/fail/always callbacks should be executed in this scenario instead.

The documentation at http://api.jquery.com/jQuery.ajax/ also does not document when statusCode callback will be invoked.

Change History (1)

comment:1 Changed 7 years ago by jaubourg

Resolution: duplicate
Status: newclosed

Duplicate of #14011.

Note: See TracTickets for help on using tickets.