Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#13999 closed bug (worksforme)

Mouse movement not tracked in example

Reported by: jasongilley70@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

I was having issues where mouse events were not being triggered so I went to the documentation on the .mouseenter event. At the bottom of the article there is a demo with 4 boxes. You can enter any box that is supposed to track mouse movement and if you move your mouse slowing left to right in a straight line, no events will be triggered. This leads me to believe there is a problem with the jquery code.

Change History (4)

comment:1 Changed 7 years ago by scottgonzalez

Resolution: worksforme
Status: newclosed

It doesn't matter how quickly or slowly you move your mouse. If you're not moving to a *different* element, the event isn't going to trigger.

comment:2 Changed 7 years ago by dmethvin

The demo on that page seems to work for me as well. http://i.imgur.com/7FTumor.png

comment:3 Changed 7 years ago by jasongilley70@…

"It doesn't matter how quickly or slowly you move your mouse. If you're not moving to a *different* element, the event isn't going to trigger."

The "mouseover" events are not fired in firefox or IE if you move slowly left to right or right to left (no up and down movement) in the mouseover box. The "mouseenter" works fine.

And what good is the "leave as closed" radio button? If I cant re-open the ticket, possibly because of a miscommunication, then there's no reason for it to be there.

comment:4 Changed 7 years ago by dmethvin

You didn't mention that the problem was browser specific in your report. Still, it works for me (both mouseover and mouseenter) on Chrome 26, Firefox 21, and IE 10. The page I am looking at, which I guessed at based on your description, was http://api.jquery.com/mouseenter/ . Head over to a place with more people like our own http://forum.jquery.com/ or StackOverfow to see whether it's just your computer or if this is some wider problem that we aren't seeing. As you might guess, though, we aren't able to fix problems we can't reproduce.

Note: See TracTickets for help on using tickets.