Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13973 closed bug (duplicate)

Accessing XML attribute named "type" broken on IE 7

Reported by: derRaab Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

I ran into an issue with jQuery 1.10.1 on IE 7. Accessing the XML attribute named "type" with $.attr( "type" ) throws an error in the new function interpolationHandler(); Here's a little test HTML document:

<!DOCTYPE html><html><head></head><body>

<!--jQuery 1.10.1 in IE 7 throws SCRIPT450 (wrong number of arguments) error in function interpolationHandler(){}-->

<script src="http://code.jquery.com/jquery-1.10.1.js"></script>

<script type="text/javascript">

var xmlString = '<list><item type="type-a" other="other-a"/><item type="type-b" other="other-b"/></list>';

var xml = $.parseXML( xmlString );

$( xml).find( "item" ).each( function() {

Always works

var otherValue = $(this).attr( "other" );

alert( otherValue );

jQuery 1.10.1 in IE 7 throws SCRIPT450 (wrong number of arguments) error in function interpolationHandler(){}

var typeValue = $(this).attr( "type" );

alert( typeValue );

});

</script></body></html>

USING JQUERY 1.9.1 WORKS JUST FINE!

Change History (1)

comment:1 Changed 6 years ago by gibson042

Resolution: duplicate
Status: newclosed

Duplicate of #13974.

Note: See TracTickets for help on using tickets.