Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#13969 closed bug (worksforme)

Issue processing XML responses: Mismatched tag. Expected: </input>.

Reported by: josep.sanz@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

From jquery 1.10.0 and 2.0.1, I have detected an issue that display the follow error in the firefox console:

  • Mismatched tag. Expected: </input>.

With the latest release 1.10.1 and 2.0.2 too exist the problem.

I prepared a simple unit test that allow you to see the issue:

Change History (11)

comment:1 Changed 7 years ago by dmethvin

Resolution: worksforme
Status: newclosed

I don't get that. Firefox 21.0. Please ask for help on a forum.

comment:2 Changed 7 years ago by anonymous

I don't get that too!!!

I Use firefox (21.0 and nightly) and jQuery 1.9.1 runs ok without showing error messages and only when upgrading to 1.10.0, begin to appear the commented error message.

This is the reason that I create the new issue.

If I have time, I will search the problem into your jquery code and I will explain more detailed the issue.

Josep.

comment:3 Changed 7 years ago by aram535@…

I'm seeing this behavior too. Just checking the script input from 1.8.6 to 1.10.1 starts to produce this error in Firefox. Odd thing is that I cannot see it anywhere in the generated code, so I'm not sure where firefox is picking it up from.

comment:4 Changed 7 years ago by dmethvin

Run Firefox without plugins. I am not seeing any problem.

comment:5 Changed 7 years ago by josep.sanz@…

I have tested using firefox --safe-mode and the error continues appearing.

comment:6 Changed 7 years ago by dmethvin

This could go on for a while unless someone who is seeing the issue (which means not us) can give more information. For example, does it provide a line number and file name?

comment:7 Changed 7 years ago by tnarg_10@…

I am also receiving this error. There is no line number or file given when the error appears. However, I have found that it is being caused by line 1407 in jquery-2.0.2.js:

	// Support: IE<9
	// Retrieving value should defer to defaultValue
	support.input = assert(function( div ) {
		div.innerHTML = "<input>";
		div.firstChild.setAttribute( "value", "" );
		return div.firstChild.getAttribute( "value" ) === "";
	});

If I change that input tag to a self-closing one, the error does not appear.

comment:8 Changed 7 years ago by gibson042

Ah, this is then analogous the the XHTML bugs we see from time to time. At any rate, it was fixed with https://github.com/jquery/sizzle/commit/decefb6cad670c778d692d99467afcf92d95bd41 and is already in edge.

comment:9 Changed 7 years ago by josep.sanz@…

I found the same issue in jquery-1.10.1.js and too, it is fixed by closing the input tag. Thanks tnarg_10@...

Well, this explain the error message!!!

comment:10 Changed 7 years ago by josep.sanz@…

Seems that closing the <input> tag in the jquery files, the error does not appear more

Thanks to all the community for believing in me!!!

comment:11 Changed 7 years ago by FranklinWhale

Good to know that this bug has been fixed in Git.

Note: See TracTickets for help on using tickets.