Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13961 closed bug (invalid)

stopImmediatePropagation does not work from inline event handler

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

When calling #stopImmediatePropagation() from an inline event handler, the event is still dispatched to registered event handlers:

http://jsfiddle.net/2YUne/

The cause for this is that a new event object is created in #dispatch() and #isImmediatePropagationStopped is lost.

Change History (3)

comment:1 Changed 6 years ago by dmethvin

Owner: set to anonymous
Status: newpending

When would you encounter this? jQuery.event.dispatch() shouldn't ever be entered with an event that has propagation stopped.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 6 years ago by anonymous

Your question doesn't make any sense to me. Did you take a look at the fiddle I provided?

Note: See TracTickets for help on using tickets.