Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13958 closed bug (duplicate)

.removeAttr() seems to cause future .attr() issues

Reported by: stephen@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

Zenphoto has a function to generate a UL of checkbox items. They are all styled with a particular style and there is an "all" checkbox item (outside of the UL) that is supposed to check or uncheck all the boxes in the UL via a javascript function.

All this worked on version 1.8.3 but fails on 1.9.1 and 1.10.0. Debugging of the situation indicates that once the $('.class').removeAttr('checked'); is issued $('.class').attr('checked','checked') will no longer mark the checkbox as checked. We have also tried to use ID instead of CLASS for these operations with the same results.

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13245.

Note: See TracTickets for help on using tickets.