Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13938 closed bug (duplicate)

jQuery 1.9+ crashes IE10 if used with iframe

Reported by: anwarjaved@… Owned by:
Priority: high Milestone: 1.10.1/2.0.2
Component: selector Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

I was trying to load a page in iframe using fancybox, this is working in jquery 1.8.3 in all browsers, but after 1.9+ ie10 crashes completely on this line

support.getById = assert(function( div ) {
		docElem.appendChild( div ).id = expando;
		return !doc.getElementsByName || !doc.getElementsByName( expando ).length;
	});

this call was made by this function

iframe.contents().find('body');

is jQuery 1.9+ is IE10 compatible?

Change History (4)

comment:1 Changed 5 years ago by dmethvin

Component: unfiledselector
Priority: undecidedhigh
Status: newopen

comment:2 Changed 5 years ago by dmethvin

Milestone: None1.10.1/2.0.2

comment:3 Changed 5 years ago by dmethvin

Resolution: duplicate
Status: openclosed

Duplicate of #13936.

comment:4 Changed 5 years ago by anonymous

Internet explorer seems to be dropping a lot of functions---the reason= who knows? I'm pretty sure theyre just getting tired of browser competitions and will soon be buried with the old netscape browsers... IE -> R.I.P. !

Note: See TracTickets for help on using tickets.