Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13924 closed bug (invalid)

getJSON ignores last dot in url

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

When i do getJSON("/users/my.username"), jQuery performs the get to "/users/my" insted. $.ajax({ url:"/users/my.username", dataType: "json"}) works as expected, so i'm currently using that

Change History (3)

comment:1 Changed 7 years ago by jocapc

I cannot reproduce it on FireFox and Chrome on WindowsXP (see http://jsfiddle.net/CYtUn/ and click on the get JSON button). I have traced it in the Firebug and Chrome developer tool and it always sends request to /users/my.username URL (it fails because this page does not exists on jsFiddle, however I can see that correct URL is sent).

Please try it on jsFiddle and provide exact platform where it can be reproduced.

comment:2 Changed 7 years ago by markelog

Owner: set to anonymous
Status: newpending

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.