Bug Tracker

Opened 7 years ago

Closed 6 years ago

#13912 closed bug (invalid)

document.activeElement IE 9 and iframe

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

There are couple of "document.activeElement" calls in jQuery code, for example in line 3255. When jQuery page is in iframe in Internet Explorer 9, these calls cause an error and the page is unable to display. I had to wrap each document.activeElement with try {} catch {} block to get my website running.

This problem cannot be reproduced with IE10 in compatibly mode,to reproduce problem, real IE9 have to be used.

Tested with jQuery 1.9.1

Change History (4)

comment:1 Changed 7 years ago by m_gol

Thanks for your report! Related: http://bugs.jquery.com/ticket/13378

comment:2 Changed 7 years ago by m_gol

Last edited 7 years ago by m_gol (previous) (diff)

comment:3 Changed 7 years ago by dmethvin

Owner: set to anonymous
Status: newpending

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.