Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#13893 closed bug (duplicate)

SSL Certificate for code.jquery.com is incorrect

Reported by: martijn@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version:
Keywords: Cc:
Blocked by: Blocking:

Description

The SSL certificate for code.jquery.com is incorrect. This makes it impossible to include jquery from this CDN on a secured website, because the browser will not load jquery by default.

Go to https://code.jquery.com/ to see what I mean.

If it *shouldn't* work, then the server should not respond on this URL at all. I hope it *should* work, in which case the certificate needs to be updated.

Change History (6)

comment:1 Changed 7 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #13322.
We encourage the use of the Google CDN if SSL is needed.

comment:2 Changed 7 years ago by martijn@…

I understand, but then the server should not respond on this url. No matter how you put it, it's something that's not right...

comment:3 Changed 7 years ago by martijn@…

To clarify - the server is trying to respond with an incorrect certificate. So it does support SSL, it's just not configured correctly.

If the server isn't *supposed* to support SSL, then it should respond with no certificate, or return a proper error, or not return anything, or something else that doesn't produce a confusing error.

comment:4 Changed 7 years ago by scottgonzalez

We're working on this. But this is not the appropriate place to repot a problem with the CDN, hence the other ticket being closed as not a bug.

comment:5 Changed 7 years ago by dmethvin

Clearly it's easy and cheap to fix on your end. On our end it's not a single server but actually an entire CDN taking requests from a large number of sites. If it were just the cost of a cert we could easily add one, but the CDN provider charges more for HTTPS access than for standard access.

We're looking to see if we can get someone to sponsor HTTPS access on our CDN, which is likely to run several thousands of dollars per month, so that you can enjoy such access without spending money or using your own server resources. In the meantime, please use another CDN or host the file locally.

comment:6 Changed 7 years ago by anonymous

I understand, and thanks for explaining.

But I have to say, the server should then not respond on HTTPS at all, should it?

Note: See TracTickets for help on using tickets.