Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13836 closed bug (duplicate)

Strings that start with a whitespace will cause appendTo() to fail.

Reported by: WhollyAnointed@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.0
Keywords: Cc:
Blocked by: Blocking:

Description

Strings that begin with a whitespace will cause appendTo() to fail. This applies to both 1.9.1 and 2.x. Previous versions didn't have this issue.

E.x: http://jsfiddle.net/4ZBdZ/1/

// This will pass!
$('<h1>PASS</h1>').appendTo('#myDiv');

// This will fail due to string starting with whitespace
$(' <h1>FAIL!  String begins with whitespace!</h1>').appendTo('#myDiv');

Change History (1)

comment:1 Changed 6 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

Duplicate of #13223.

Note: See TracTickets for help on using tickets.