Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13795 closed bug (notabug)

.slideToggle() on .contents() throws error

Reported by: flipvrijn@… Owned by: flipvrijn@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Version: jQuery 1.9.1

Browser: Chrome 26.0.1410.63

OS: Mac OS 10.7.5

Demo: http://jsfiddle.net/nzyM8/

What I tried to do: I tried to slide toggle the contents of a fieldset using slideToggle() on .contents().

Step-by-step instruction:

  1. Open the demo
  2. Click on the legend in the fieldset

What I expected: The contents of the fieldset would slide toggle

What actually happened: I received the following error: "Uncaught TypeError: Cannot set property 'cur' of undefined " at line 3888.

Change History (3)

comment:1 Changed 6 years ago by dmethvin

Owner: set to flipvrijn@…
Status: newpending

Did you mean this? http://jsfiddle.net/nzyM8/1/

Using .contents() there is really strange.

comment:2 Changed 6 years ago by anonymous

Hmm, indeed that's the effect I wanted to create. Better use siblings then...

comment:3 Changed 6 years ago by dmethvin

Resolution: notabug
Status: pendingclosed
Note: See TracTickets for help on using tickets.