Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13766 closed bug (duplicate)

jQuery.ajax is modifying the data value

Reported by: dawson.green@… Owned by: dawson.green@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

I stumbled across some odd behavior while using jquery-1.9.1.min.js. I am running some test post requests to verify my site is communicating with my server correctly. When testing some random data, I entered in "??" for one of the form fields and did a transmission.

Prior to calling jQuery.ajax, my data was of the form:

JSON.stringify({
    key1: 23,
    key2: 150,
    key3: "1234e",
    key4: "??",
    key5: false
});

The result of that code snippet was my argument for jQuery.ajax(). However, the data transmitted replaced key4's value with "jQuery1910034090394619852304_1365631018644". I am not quite sure why, but chrome's network tool under the developer tools confirms that the jQuery string was in the transmitted form data. I went back and tested this on a jquery-1.7.2 ajax call and confirmed that 1.7.2 did not have this problem.

I am uncertain how to include a jsfiddle with this considering that the failure is ajax related. If any further information is required, please let me know how I can try to provide it.

OS: Windows 7 (64-bit) Browser: Chrome v24.0.1312.57

Change History (2)

comment:1 Changed 7 years ago by m_gol

Owner: set to dawson.green@…
Status: newpending

Could you write the exact AJAX jQuery call you used when you experienced this behavior? I can't reproduce it.

BTW, you should really update your Chrome, it's two major versions behind the current one!

Last edited 7 years ago by m_gol (previous) (diff)

comment:2 Changed 7 years ago by jaubourg

Resolution: duplicate
Status: pendingclosed

Duplicate of #8417.
See the following comment: http://bugs.jquery.com/ticket/8417#comment:20

Note: See TracTickets for help on using tickets.