Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13736 closed bug (duplicate)

CheckBox Error

Reported by: stanislav.victorovich@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hello, jQuery v1.9.1 have problem with checkbox.

When we have one checkbox that check other checkboxes, that is work only to steps.

$(document).ready(function(){

$("#all_check").click(function() {

if ($("#all_check").is(':checked')) {

$('input[name*=checkbox]').attr('checked', true);

} else {

$('input[name*=checkbox]').attr('checked', false);

}

});

});

Change History (4)

comment:1 Changed 7 years ago by dmethvin

Resolution: notabug
Status: newclosed

Please ask for help on the forum.

comment:2 Changed 7 years ago by stanislav.victorovich@…

<form action="" id="example_group3">

<input type="checkbox" class="example_check" name="cbname3[]" value="1" /> <input type="checkbox" class="example_check" name="cbname3[]" value="2" /> Отметить все:<input type="checkbox" name="cbname3[]" value="14" id="example_maincb" />

</form> <script type="text/javascript">

$(document).ready( function() {

$("#example_maincb").click( function() {

if($('#example_maincb').is(':checked')){

$('.example_check:enabled').attr('checked', true);

} else {

$('.example_check:enabled').attr('checked', false);

}

});

});

</script>

Try this example. Click to #example_maincb more then two times. When i use jQuery 1.8 its work correct.

comment:3 Changed 7 years ago by m_gol

Resolution: notabug
Status: closedreopened

comment:4 Changed 7 years ago by m_gol

Resolution: duplicate
Status: reopenedclosed

Duplicate of #13667.

Note: See TracTickets for help on using tickets.