Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13707 closed bug (duplicate)

CSS warning and error from Opera

Reported by: horstman.jesse@… Owned by: horstman.jesse@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

I am using Opera 12.14 and getting an error from jquery about invalid value for property zoom usage in jquery 1.7.2 and also in 1.9.1.

Additionally I am seeing warnings about box-sizing.

I have printed the error console messages generated by this simple example within this example.

http://jsbin.com/odafoz/1/

Change History (10)

comment:1 Changed 6 years ago by m_gol

Please provide a test case at http://jsfiddle.net. It's really hard to tell what's the problem from a description so general.

Also, note that Opera complains about a lot of CSS properties, i.e. all it doesn't recognize, including prefixed values. This is Opera's problem, jQuery can do nothing about that.

comment:2 Changed 6 years ago by m_gol

Owner: set to horstman.jesse@…
Status: newpending

comment:3 in reply to:  1 Changed 6 years ago by horstman.jesse@…

http://jsfiddle.net/SYEPx/

This jsfiddle is almost the same test case I provided with jsbin.

Is the zoom related error killing the script or does jquery still continue to function? Since these css properties are injected, can this injection not take place if the browser is Opera?

Some lines of interest are: 1518, 1512, 1456, 1504, and 1495

comment:4 Changed 6 years ago by horstman.jesse@…

Last edited 6 years ago by horstman.jesse@… (previous) (diff)

comment:5 Changed 6 years ago by m_gol

You just pasted the output from Opera Dragonfly console, we need an actual test case so that we can reproduce it ourselves. Please, prepare a minimal example exhibiting a problem on jsfiddle.

As for the errors, unrecognized CSS properties never stop any browser from parsing further CSS rules, this is how CSS works. These errors are completely harmless.

Besides, this info is outdated, the zoom property is defined in CSS3 so it's perfectly standard now.

comment:6 Changed 6 years ago by m_gol

Resolution: duplicate
Status: pendingclosed

Duplicate of #13569.
This is not a bug.

comment:7 Changed 6 years ago by horstman.jesse@…

I'm grateful for your work on this and that you are taking the time to look at this issue, but I don't understand why you are dismissing it.

If you run either of those test cases in Opera you will get those errors. That is the simplest test case possible. The mere inclusion of jquery produces those errors and warnings.

Yes, I have done some further testing and I concur that the CSS error does not break the library, but it would still be nice to not see ten error messages every time the page using jquery loads.

Did you try it with Opera? Here is a ridiculous test case: http://jsfiddle.net/9pSVc/

Regarding the CSS3 standard release including zoom, by that argument you may as well stop trying to support old versions of IE and all the nuances of javascript support. One of the big draws of jQuery in my mind is that you guys have smoothed over the incompatibilities. If you only target the standard, then you will soon find jQuery doesn't really work on any browser all of the time. That's my opinion, no disrespect intended.

I wish that you would fix this issue, but in the end it is your decision. I am not familiar enough with the internals of jQuery and how you test changes against multiple targets to feel confident submitting a bug fix myself. In the end, thank you for your consideration.

Last edited 6 years ago by horstman.jesse@… (previous) (diff)

comment:8 Changed 6 years ago by m_gol

The problem is nothing really can be done on jQuery's end about it. jQuery performs some support tests to know what it can rely on. All of these tests are performed on dummy divs that are removed from the DOM after testing is complete.

In cases where sth is really applied to DOM elements, like zoom set to 1 in old IE, it's enclosed within if checks so these changes are not applied to Opera.

Moreover, regular Opera users don't use the web console so it affects only developers.

comment:9 Changed 6 years ago by m_gol

BTW, most of errors in your jsFiddle test case come from jsFiddle itself, not jQuery. Also, 10 errors is not a lot, especially that most of them are vendor-prefixed ones that Opera really shouldn't complain about.

Also, all of this will be gone with the next Chromium-based Opera.

comment:10 Changed 6 years ago by horstman.jesse@…

True point about the Opera overhaul. Thank you for your time and your efforts.

Note: See TracTickets for help on using tickets.