Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13693 closed bug (duplicate)

Jsonp request bug

Reported by: apdmatos Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hey guys,

I have been using jquery, and when using a jsonp request I experienced some strange behaviour.

If for some reason, after a jsonp request, it is canceled, you will get a javascript error when the server responds.

I have reproduced the bug here: https://github.com/apdmatos/jquery-jsonp-bug Or you can see it on jsfiddle too: http://jsfiddle.net/XvW4B/

Ps: I have a patch for this problem and I will submit it too.

Change History (1)

comment:1 Changed 7 years ago by markelog

Resolution: duplicate
Status: newclosed

Duplicate of #8744.

Last edited 7 years ago by markelog (previous) (diff)
Note: See TracTickets for help on using tickets.