Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13675 closed bug (duplicate)

KeyError: 'captcha_redirect'

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'd63ba6ef6c93024f54e4e3bc',
 'recaptcha_challenge_field': u'03AHJ_VuuOHzsNcyW2jarXot-tEtomJHbiAqK8JPEMhid4UNOXEvAxYNZ3Fq9pFL6ZTQm2TpRdHCyanz5A2G4YjYEJeydY6tDuvsBq9Ouxz5ikBEJ_MG78U7clcwu52EJ6zPLGm8de8fjfk8q9OhXiT1uCY4t9jXjfBzbA0gUenLZPcep4WL8Eo-8',
 'recaptcha_response_field': u'exasta Life'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1451.3 Safari/537.36

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (1)

comment:1 Changed 7 years ago by m_gol

Resolution: duplicate
Status: newclosed

Duplicate of #13676.

Note: See TracTickets for help on using tickets.