Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13650 closed bug (duplicate)

$("select").val setter has a different behavior from Chrome to IE

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: attributes Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

When you set a drop down value in Chrome where there is no matching option value, it will fail and set the value to the first option in the drop down. In IE, if you set a value that does not exist in the options, it will still set it as a non-existant option.

Confirmed on 1.9.1 and 1.4.2 with Chrome 21.0.1180.83 m and IE9

Change History (1)

comment:1 Changed 7 years ago by gibson042

Component: unfiledattributes
Resolution: duplicate
Status: newclosed

Duplicate of #13514.
Thanks; this will be corrected in the next release.

Note: See TracTickets for help on using tickets.