Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13600 closed bug (duplicate)

ajax automatic reponse mimetype parsing does not work properly when run from file://

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

If you run an ajax request to SERVER_URI without explicit dataType spec, the response normally is handled according to the returned mime-type (Content-Type http header). This does not seem to work when running the Website locally (with an ajax request to a remote server) from your filesystem (file:// protocol) in a current Firefox 19.0.2).

As you can imagine this causes weird, hard to track-down issues when the code is deployed on a server, as the behavior of jquery suddenly changes to autoparse depending on mimetype.

This issue seems to be related to (but not the same, as the ajax request is not local but to a fixed full URI): http://stackoverflow.com/questions/1828228/why-does-jquery-insist-my-plain-text-is-not-well-formed

Change History (1)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13599.

Note: See TracTickets for help on using tickets.