Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13590 closed bug (duplicate)

.trigger() does not pass extraParameters to checkbox's click handler

Reported by: ultcombo Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

.trigger()'s second parameter allows us to pass extra parameters to the event handler.

There's a bug in jQuery 1.8.x-git where the second parameter is not passed to a checkbox's click handler.

Test case - it works consistently when downgrading to jQuery 1.7.2

Also the bug does not appear when triggering a click on a non-checkbox input, nor when triggering another checkbox's event such as change. This issue seems to be intrinsically related with triggering a click event on a checkbox input.

I know this is a rare corner-case but can be tagged as back-compat. Original finder of this bug is SO's user2154919 (link).

Change History (2)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13428.

comment:2 Changed 6 years ago by ultcombo

Oh that was quick, thanks for finding the duplicate so fast @dmethvin. =] Thing is, the other ticket claims to work in 1.8.3 while this one does not. Well I believe the source of the problem is the same then.

Note: See TracTickets for help on using tickets.