Bug Tracker

Opened 14 years ago

Closed 14 years ago

Last modified 10 years ago

#1359 closed bug (fixed)

Create input of type checkbox not working in IE

Reported by: stickmus Owned by:
Priority: minor Milestone: 1.2
Component: core Version: 1.1.4
Keywords: Cc:
Blocked by: Blocking:

Description

$('<input">').attr('type', 'checkbox');

This isn't working in IE, works in FF

As a workaround the following does work

$('<input type="checkbox">')

Change History (4)

comment:1 Changed 14 years ago by john

need: ReviewTest Case

The problem is that, in IE, you can't change the type of an input element once it's been created.

comment:2 Changed 14 years ago by shameister

For this case no fix is available. Reason is microsofts read/write-once rule for input-elements.

You can 'ship' this problem, by using $('<input type="checkbox">') or generate the element manually.

tempVar = document.createElement('input');
tempVar.setAttribute('type', 'checkbox');
$('form').append(tempVar);

This doesn´t turn off the read/write-once-rule'''

Microsofts official statement you find here: http://msdn2.microsoft.com/en-us/library/ms534700.aspx

comment:3 Changed 14 years ago by john

Resolution: fixed
Status: newclosed

comment:4 Changed 14 years ago by john

Milestone: 1.1.41.2
Version: 1.1.31.1.4
Note: See TracTickets for help on using tickets.