Bug Tracker

Opened 15 years ago

Closed 15 years ago

#1358 closed bug (duplicate)

Safari 1.3 still crashes with version 1.1.3.1

Reported by: tom.kentell Owned by:
Priority: major Milestone: 1.1.4
Component: build Version: 1.1.3
Keywords: Safari, crashing, 1.1.3, 1.1.3.1 Cc:
Blocked by: Blocking:

Description

Just tried the new version with Safari, i included it on a page with nothing else on and it crashed my version of Safari 1.3.2 (v312.6).

I Installed version 1.1.3 yesterday and it also crashed Safari a few times but it then randomly seemed to stop crashing with the following code:

$(document).ready(function() {

$("#mainnav>ul>li:last-child ul").css("left", "-9999px"); $("#mainnav>ul>li:last-child ul").css("width", "167px"); $("#mainnav>ul>li:last-child ul").css("display", "none"); $("#mainnav>ul>li:last-child").focus(slideMenuDown, slideMenuUp); $("#mainnav>ul>li:last-child").hover(slideMenuDown, slideMenuUp);

});

function slideMenuDown() {

$(this).addClass("currentdrop"); $("ul", this).css("left", "auto"); $("ul", this).slideDown("slow");

}

function slideMenuUp() {

$("ul", this).slideUp(function(){

$(this.parentNode).removeClass("currentdrop"); $("ul", this).css("left", "-9999px");

});

}

Change History (1)

comment:1 Changed 15 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #1331.

Note: See TracTickets for help on using tickets.