Skip to main content

Bug Tracker

Side navigation

#13497 closed bug (notabug)

Opened February 21, 2013 09:31PM UTC

Closed February 25, 2013 09:12PM UTC

removeAttribute( jQuery.expando ); crashes ie7

Reported by: Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: git
Keywords: Cc:
Blocked by: Blocking:

When cloning an object, one of the elements is an input box. It tries to call removeAttribute( jQuery.expando ); and this crashes the ie7 browser. This is in version 1.8.2, if we go backwards to 1.7.2 this problem goes away

Attachments (0)
Change History (7)

Changed February 21, 2013 10:11PM UTC by rwaldron comment:1

owner: →
status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists—you may need to change this to a specific version depending on the test case.

To get you started, use this boilerplate: Open the link and click to "Fork" (in the top menu) to begin.

Also, please read:

Changed February 21, 2013 10:13PM UTC by dmethvin comment:2

Followup: With your test case please explain whether this is a problem in real honest-to-goodness IE7 or whether you are testing in a Frankenstein mode such as IE10 in IE7 Compatibility View. They are NOT the same thing.

Changed February 22, 2013 02:21AM UTC by anonymous comment:3

It only happens in real IE7. We tried to reproduce it in IE9 in IE7 mode and it failed to produce the error. not sure why removing the expando attribute crashes the browser.

Changed February 22, 2013 02:37PM UTC by dmethvin comment:4

You forgot the test case.

Changed February 22, 2013 03:42PM UTC by anonymous comment:5

I am working on putting that together for you...

Changed February 25, 2013 06:15PM UTC by anonymous comment:6

You can close this ticket, we tracked down the issue and it was related to a recent code change. There was another issue, and in solving that issue this problem also got fixed It is odd that 1.7.2 worked and 1.8.2 didn't but anyway...

Changed February 25, 2013 09:12PM UTC by dmethvin comment:7

resolution: → notabug
status: pendingclosed