Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13482 closed bug (duplicate)

Can't add data to an item that hasnt been added to the dom

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: data Version: git
Keywords: Cc:
Blocked by: Blocking:

Description

Given something like:

var option = $('<option/>');

For adding to a Select list, you can't do:

var option = $('<option/>').test('hello').val('world').data('additional-info', 123);

The output doesn't include the data.

Change History (1)

comment:1 Changed 6 years ago by gibson042

Component: unfileddata
Resolution: duplicate
Status: newclosed

Duplicate of #13130.

Note: See TracTickets for help on using tickets.