Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13453 closed bug (duplicate)

:visible for input type=hidden behaves differently in different browsers

Reported by: erobrich@… Owned by: erobrich@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Consider this markup:

<input type="hidden" id="someid" />

Consider this jQuery:

$("#someid").is(":visible")

In Chrome 24 and IE 9 it yields false (correct), in IE 8 it yields true (incorrect).

Change History (4)

comment:1 Changed 7 years ago by mikesherov

Owner: set to erobrich@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists—you may need to change this to a specific version depending on the test case.

To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

comment:2 in reply to:  1 Changed 7 years ago by erobrich@…

Status: pendingnew

Here is a jsFiddle example: http://jsfiddle.net/robrich/WNZqJ/ When run in Chrome 24 and IE 9 it yields false (correct), in IE 8 it yields true (incorrect).

comment:3 Changed 7 years ago by bjohn465

Using IE 8 on Windows XP and Windows 7 in BrowserStack, I get "false" when viewing the test case at http://fiddle.jshell.net/robrich/WNZqJ/show/

comment:4 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13132.

Note: See TracTickets for help on using tickets.