Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13431 closed bug (duplicate)

Error in parseJSON:

Reported by: odesuk@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

I had to update code to fix this issue for me.

LIne 548 in jquery-1.9.1.js Error in IE 10: Invalid character

Added check for null & undefined before calling window.JSON

if (data === null
data === undefined) {

return data;

}

Attempt to parse using the native JSON parser first if ( window.JSON && window.JSON.parse ) {

return window.JSON.parse( data );

}

...

Change History (1)

comment:1 Changed 7 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

Duplicate of #13430.

Note: See TracTickets for help on using tickets.