Skip to main content

Bug Tracker

Side navigation

#1341 closed bug (fixed)

Opened July 02, 2007 03:19PM UTC

Closed July 04, 2007 09:19PM UTC

jQuery 1.1.3 fails completely in Konqueror 3.5.5 !

Reported by: frando Owned by:
Priority: critical Milestone: 1.1.4
Component: core Version: 1.1.3
Keywords: konqueror Cc:
Blocked by: Blocking:

Konqueror always had its problems with Javascript and jQuery. With 1.1.2, most stuff worked, though. 1.1.3 now doesn't work at all. Everything fails. I think it doesn't even get unpacked correctly.

Here's what Konqueror reports when visiting (in the JavaScript errors window):

Error: TypeError: Null value

Error: TypeError: Value undefined (result of expression jQuery.find) is not an object. Cannot be called.

Error: TypeError: Value undefined (result of expression $(document).ready) is not an object. Cannot be called.

Attachments (0)
Change History (5)

Changed July 02, 2007 03:24PM UTC by frando comment:1

It's not related to the packer, using the uncompressed version results in the same error.

Changed July 02, 2007 08:40PM UTC by batiste comment:2


Compression slowness in konqueror have been fixed with Konqueror 3.5.7 but it's broken again.

Beside this I am not sure that javascript compression is realy a good idea :

Changed July 03, 2007 08:45AM UTC by batiste comment:3

Hello again,

I toke 5 minutes this morning and I changed this line

version: b.match(/.+(?:rv|it|ra|ie|la)[\\/: ]([\\d.]+)/)[1],

In this one

version: b.match(/.+(?:rv|it|ra|ie|ml)[\\/: ]([\\d.]+)/)[1],

And jQuery seems to work again on Konqueror ...

Changed July 03, 2007 08:21PM UTC by aportale comment:4

Cool! Thanks, it really seems to work. In order to explain the fix, Konqueror (on kubuntu) returns a user agent string:

mozilla/5.0 (compatible; konqueror/3.5; linux) khtml/3.5.6 (like gecko)(kubuntu)

The fix takes the version number after khtml/

Changed July 04, 2007 09:19PM UTC by john comment:5

resolution: → fixed
status: newclosed

Fixed in SVN.