Bug Tracker

Opened 10 years ago

Closed 10 years ago

#13369 closed bug (duplicate)

Set all checkbox checked doesn't work in jquery 1.9.0

Reported by: [email protected] Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

When you set all checkbox checked using jquery 1.9.0 work the first time, but the next doesn't work.

Now if you change it to jQuery 1.8.3 if it works.

Check here: JQuery 1.8.3: http://jsfiddle.net/Z7ZuW/ JQuery 1.9.0: http://jsfiddle.net/eD7sU/

Change History (1)

comment:1 Changed 10 years ago by gibson042

Resolution: duplicate
Status: newclosed

Duplicate of #13245.
You should be using .prop instead of .attr to interact with the dynamic state of checkboxes: http://jquery.com/upgrade-guide/1.9/#attr-versus-prop-

Please use the jQuery migrate plugin to detect other such upgrade issues.

Note: See TracTickets for help on using tickets.