Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13367 closed bug (notabug)

removeClass() does not remove all class in v1.9.0

Reported by: balaram@… Owned by: balaram@…
Priority: undecided Milestone: None
Component: attributes Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

$("#a1").removeClass() does not remove all class from

<a id="a1" href="#qno1" class="ans mark unmark">1</a>

individual class are removed using $("#a1").removeClass("ans")...

but jquery v1.8.3 is removed all classes.

The elements are loaded through ajax.

Change History (7)

comment:1 Changed 6 years ago by gibson042

Owner: set to balaram@…
Status: newpending

Works for me: http://jsfiddle.net/jzE3m/

We'll only be able to assess this ticket further if you provide a reduced test case of your own.

comment:2 Changed 6 years ago by scottgonzalez

I assume you're using jQuery UI. See http://bugs.jqueryui.com/ticket/9015.

I'll leave this open until we get confirmation.

comment:3 Changed 6 years ago by balaram

Yes, i am using jQuery UI. It is only happen only in jQuery UI.

You are recommandate using .removeAttr('class') rather than .removeClass().

So how about .removeClass()???

Version 0, edited 6 years ago by balaram (next)

comment:4 Changed 6 years ago by gibson042

Component: unfiledattributes
Resolution: notabug
Status: pendingclosed

comment:5 Changed 6 years ago by scottgonzalez

#13411 is a duplicate of this ticket.

comment:6 Changed 6 years ago by scottgonzalez

#13531 is a duplicate of this ticket.

comment:7 Changed 6 years ago by scottgonzalez

#14311 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.