Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13358 closed bug (duplicate)

Checkbox attr checked

Reported by: joubert@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

I did a test in my application and some features are not working on checkbox, see my log below firebug:

$("#lol");

Object[input#lol] /* Ok, my checkbox */

$("#lol").attr('checked');

undefined

[Checked in browser]

$("#lol").attr('checked');

undefined

$("#lol").attr('checked', 'checked');

Object[input#lol]

$("#lol").removeAttr('checked');

Object[input#lol] /* Works */

$("#lol").attr('checked', );

Object[input#lol]

$("#lol").attr('checked', null);

Object[input#lol] /* Works */

$("#lol").attr('checked', true);

Object[input#lol]

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13245.

Note: See TracTickets for help on using tickets.