Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#133 closed bug (invalid)

Slide Bug

Reported by: Jörn Owned by:
Priority: major Milestone:
Component: effects Version:
Keywords: Cc:
Blocked by: Blocking:

Description

See example: http://fuzz.bassistance.de/slidebug/starterkit.html The problem appears with in Opera 9.01, Firefox 1.5.0.6 and IE 6 are fine.

Change History (5)

comment:1 Changed 13 years ago by Jörn

Priority: majorcritical

I modified the example, now the bug also appears with Firefox, only IE 6 is doing fine. I limited the width of the dl element, this screws FF up.

comment:2 Changed 13 years ago by john

Milestone: 1.0
Resolution: fixed
Status: newclosed

I fixed the Opera bug - however, the other bug is far more complicated and probably not fixable anytime soon. The issue is that since the element is hidden (display: none) I have to break it out of body in order to avoid any flashes of content, when I determine the "true" height/width. Unfortunately, since browsers don't feel like giving the correct height/width for display:none content, this isn't going to be resolved, unfortunately.

See, the quick fix is just to not change the position to 'absolute' - but the problem is that any content beneath it will be shoved, temporarily, out of position - which is highly undesirable. So, long story short, if you want to slideDown something with a width:auto *within* something with a fixed width container, you'll need to limit the width in some way using CSS.

comment:3 Changed 13 years ago by anonymous

Component: ajax
Priority: blocker
Resolution: invalid
Status: reopenedclosed
Type: bug

comment:4 Changed 13 years ago by Otto

Cc: Otto added; "" removed
Component: ajax1
Keywords: Otto added; "" removed
Milestone: 1
Priority: blocker1
Summary: slideUp/Down buggy in Opera 9.01Otto
Type: bug1
Version: 1

comment:5 Changed 13 years ago by john

Cc: Otto removed
Component: 1fx
Keywords: Otto removed
Milestone: 1
Priority: 1major
Summary: OttoSlide Bug
Type: 1bug
Version: 1
Note: See TracTickets for help on using tickets.